Satcat - Satcat Control Center Interruption – Incident details

All systems operational

Satcat Control Center Interruption

Resolved
Degraded performance
Started 5 days agoLasted 19 minutes

Affected

Satcat.com

Degraded performance from 8:53 PM to 9:12 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience!

  • Investigating
    Investigating

    We have received reports that some user are experiencing issues loading the Control Center on Satcat. Our team is investigating the issue.