Satcat - Satcat experiencing service degradation – Incident details

All systems operational

Satcat experiencing service degradation

Resolved
Major outage
Started 5 days agoLasted 30 minutes

Affected

Satcat.com

Major outage from 3:04 PM to 3:15 PM, Degraded performance from 3:15 PM to 3:33 PM

Satcat API

Major outage from 3:04 PM to 3:15 PM, Degraded performance from 3:15 PM to 3:33 PM

On-Demand Screening

Major outage from 3:04 PM to 3:15 PM, Degraded performance from 3:15 PM to 3:33 PM

Third-Party CDM Ingestion

Major outage from 3:04 PM to 3:15 PM, Degraded performance from 3:15 PM to 3:33 PM

CDM Notifications

Major outage from 3:04 PM to 3:15 PM, Degraded performance from 3:15 PM to 3:33 PM

Updates
  • Resolved
    UTC
    Resolved

    We are now observing nominal performance of the system. We will continue to monitor for any further interruptions.

  • Monitoring
    UTC
    Monitoring

    We have rolled out an infrastructure change to mitigate the issue and are observing recovery of system performance. We are continuing to monitor the system.

  • Investigating
    UTC
    Investigating

    Some users are currently experiencing issues connecting to Satcat. We are investigating the problem and working to restore access as quickly as possible.